Deploying Through Seed

Do these tests run for you locally?

Thank you for your quick response!

I was going according to “Deploying Through Seed” chapter.
Firstly from directory ‘services/notes’ I ran:
$ npm version patch

after that I ran:
$ git push

but nothing happened. And I ran:

  • git add .
  • git commit
  • git push

After that the deploying process started, but it was stopped due to the error

The screenshot in the previous message is from page of SEED website

After I ran the test locally and it was OK:

Hmm that seems right. Can you email me a link the build that failed? I’ll ask the team to take a look. jay@seed.run

Hi @jayair. Do we have any updates on this? I am facing the same issue.

Can make sure to update to the latest version?

Hi @jayair

I did update to the latest version and I am still seeing the same issue. Please do let me know if you need any info from my side.

I just checked up on the issue above with the team. I think it’s because of the new npm version. The new versions have a lock file that isn’t backwards compatible. If you are using npm 7, you can either try to downgrade and use npm 6 locally. Or remove the package.json lock file from git.

Thank you so much @jayair. Removing the package.json lock file from git fixed the issue.

1 Like

Im getting the following error:

Error: There was a problem transpiling the Lambda handler: ✘ [ERROR] Could not resolve "stripe"
    backend/functions/billing.js:1:19:
      1 │ import Stripe from "stripe";
        ╵                    ~~~~~~~~
  You can mark the path "stripe" as external to exclude it from the bundle, which will remove this error.
    at Object.bundle (file:///tmp/seed/source/node_modules/@serverless-stack/core/dist/runtime/handler/node.js:161:23)
    at Module.bundle (file:///tmp/seed/source/node_modules/@serverless-stack/core/dist/runtime/handler/index.js:16:16)
    at new Function (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Function.js:222:45)
    at Function.fromDefinition (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Function.js:389:20)
    at Api.createFunctionIntegration (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Api.js:491:27)
    at file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Api.js:378:26
    at Api.addRoute (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Api.js:408:11)
    at file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Api.js:101:18
    at Array.forEach (<anonymous>)
    at Api.addRoutes (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Api.js:100:29)
    at new Api (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/Api.js:50:14)
    at EmptyStack.ApiStack (file:///tmp/seed/source/.build/lib/index.js:37:15)
    at stack (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/FunctionalStack.js:15:35)
    at App.stack (file:///tmp/seed/source/node_modules/@serverless-stack/resources/dist/App.js:284:16)
    at Module.main (file:///tmp/seed/source/.build/lib/index.js:135:27)
    at file:///tmp/seed/source/.build/run.mjs:92:16
Notices refreshed
There was an error synthesizing your app.
ERROR:   You can mark the path "stripe" as external to exclude it from the bundle, which will remove this error.

I am not getting this error locally. Any idea how to solve this one?

Hey @frank if you are still logged in-- uh little help on this one?

The seed service doesn’t seem to be able to install the stripe package when it runs the seed yml script we added at the beginning of this chapter. Any idea what is going on here? I assume it is my error but I can’t find it.

Can you check if you have stripe in your backend or services folder? demo-notes-app/package.json at main · serverless-stack/demo-notes-app · GitHub

Thanks @frank for getting back to me so fast. Yes my backend/package.json file has stripe listed as a dependency. It is identical to the file you referenced in your link. I also installed the complete stripe package in the frontend and tried another build but it returned the same error.